package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) *\"[^\"]+\" *|[^\r\n\"]+`)
var str = `"Content1
block"
Contentn2
New conenet "
Conetent 3"
"Content1 \r\n block" \r\n Contentn2 \r\n New conenet " \r\n Conetent 3"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}