// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m) *\"[^\"]+\" *|[^\r\n\"]+"#).unwrap();
let string = "\"Content1
block\"
Contentn2
New conenet \"
Conetent 3\"
\"Content1 \\r\\n block\" \\r\\n Contentn2 \\r\\n New conenet \" \\r\\n Conetent 3\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}