using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *\""[^\""]+\"" *|[^\r\n\""]+";
string input = @"""Content1
block""
Contentn2
New conenet ""
Conetent 3""
""Content1 \r\n block"" \r\n Contentn2 \r\n New conenet "" \r\n Conetent 3""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}