$re = '/ *\"[^\"]+\" *|[^\r\n\"]+/m';
$str = '"Content1
block"
Contentn2
New conenet "
Conetent 3"
"Content1 \\r\\n block" \\r\\n Contentn2 \\r\\n New conenet " \\r\\n Conetent 3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);