re = / *\"[^\"]+\" *|[^\r\n\"]+/m
str = '"Content1
block"
Contentn2
New conenet "
Conetent 3"
"Content1 \\r\\n block" \\r\\n Contentn2 \\r\\n New conenet " \\r\\n Conetent 3"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end