#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@\w*handle\w*"
Local $sString = "@handle what is your problem?" & @CRLF & _
"" [RETURN '@handle']" & @CRLF & _
"what is your problem @handle?" & @CRLF & _
"" [RETURN '@handle']" & @CRLF & _
"@123handle what is your problem @handle123?" & @CRLF & _
" [RETURN '@123handle', '@handle123'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")