$re = '/@\w*handle\w*/';
$str = '@handle what is your problem?
" [RETURN \'@handle\']
what is your problem @handle?
" [RETURN \'@handle\']
@123handle what is your problem @handle123?
[RETURN \'@123handle\', \'@handle123\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);