// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"@\w*handle\w*").unwrap();
let string = "@handle what is your problem?
\" [RETURN '@handle']
what is your problem @handle?
\" [RETURN '@handle']
@123handle what is your problem @handle123?
[RETURN '@123handle', '@handle123'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}