import Foundation
let pattern = #"@\w*handle\w*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@handle what is your problem?
" [RETURN '@handle']
what is your problem @handle?
" [RETURN '@handle']
@123handle what is your problem @handle123?
[RETURN '@123handle', '@handle123'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)