using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\w*handle\w*";
string input = @"@handle what is your problem?
"" [RETURN '@handle']
what is your problem @handle?
"" [RETURN '@handle']
@123handle what is your problem @handle123?
[RETURN '@123handle', '@handle123'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}