use strict;
my $str = '@handle what is your problem?
" [RETURN \'@handle\']
what is your problem @handle?
" [RETURN \'@handle\']
@123handle what is your problem @handle123?
[RETURN \'@123handle\', \'@handle123\'';
my $regex = qr/@\w*handle\w*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}