import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@\\w*handle\\w*";
final String string = "@handle what is your problem?\n"
+ "\" [RETURN '@handle']\n"
+ "what is your problem @handle?\n"
+ "\" [RETURN '@handle']\n"
+ "@123handle what is your problem @handle123?\n"
+ " [RETURN '@123handle', '@handle123'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}