# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(?!\s)|[()\[\]]+\s+[()\[\]]+(?=\.)|(\s)/$1/g;t' <<< "H o w T o C r a f t () [.zip
V i d e o G a m e () [.zip"