const regex = /\s(?!\s)|[()\[\]]+\s+[()\[\]]+(?=\.)|(\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(?!\\s)|[()\\[\\]]+\\s+[()\\[\\]]+(?=\\.)|(\\s)', 'g')
const str = `H o w T o C r a f t () [.zip
V i d e o G a m e () [.zip`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);