using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?!\s)|[()\[\]]+\s+[()\[\]]+(?=\.)|(\s)";
string substitution = @"$1";
string input = @"H o w T o C r a f t () [.zip
V i d e o G a m e () [.zip";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}