import re
regex = re.compile(r"\s(?!\s)|[()\[\]]+\s+[()\[\]]+(?=\.)|(\s)")
test_str = ("H o w T o C r a f t () [.zip\n"
"V i d e o G a m e () [.zip")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)