use strict;
my $str = 'H o w T o C r a f t () [.zip
V i d e o G a m e () [.zip';
my $regex = qr/\s(?!\s)|[()\[\]]+\s+[()\[\]]+(?=\.)|(\s)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";