$re = '/\s(?!\s)|[()\[\]]+\s+[()\[\]]+(?=\.)|(\s)/';
$str = 'H o w T o C r a f t () [.zip
V i d e o G a m e () [.zip';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;