# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<p>((?:(?!<\/?blockquote).)*?)<\/p>(?=(?:(?!<\/?blockquote).)*<\/blockquote>)/<div>\1<\/div>/sg;t' <<< "<blockquote>
<p>paragraph 1</p>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<p>paragraph 2</p>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>"