$re = '@<p>((?:(?!</?blockquote).)*?)</p>(?=(?:(?!</?blockquote).)*</blockquote>)@s';
$str = '<blockquote>
<p>paragraph 1</p>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<p>paragraph 2</p>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>';
$subst = "<div>\1</div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;