re = /<p>((?:(?!<\/?blockquote).)*?)<\/p>(?=(?:(?!<\/?blockquote).)*<\/blockquote>)/
str = '<blockquote>
<p>paragraph 1</p>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<p>paragraph 2</p>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>'
subst = '<div>\\1</div>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result