import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>((?:(?!</?blockquote).)*?)</p>(?=(?:(?!</?blockquote).)*</blockquote>)";
final String string = "<blockquote>\n"
+ " <p>paragraph 1</p>\n"
+ "</blockquote>\n"
+ "<p>paragraph 1 outside blockquote</p>\n"
+ "<blockquote>\n"
+ " <p>paragraph 2</p>\n"
+ " <p>paragraph 3</p>\n"
+ "</blockquote>\n"
+ "<p>paragraph 2 outside blockquote</p>";
final String subst = "<div>\\1</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}