import Foundation
let pattern = #"<p>((?:(?!</?blockquote).)*?)</p>(?=(?:(?!</?blockquote).)*</blockquote>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<blockquote>
<p>paragraph 1</p>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<p>paragraph 2</p>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<div>\1</div>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)