use strict;
my $str = '<blockquote>
<p>paragraph 1</p>
</blockquote>
<p>paragraph 1 outside blockquote</p>
<blockquote>
<p>paragraph 2</p>
<p>paragraph 3</p>
</blockquote>
<p>paragraph 2 outside blockquote</p>';
my $regex = qr@<p>((?:(?!</?blockquote).)*?)</p>(?=(?:(?!</?blockquote).)*</blockquote>)@sp;
my $subst = '<div>\\1</div>';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";