#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)<p>((?:(?!</?blockquote).)*?)</p>(?=(?:(?!</?blockquote).)*</blockquote>)"
Local $sString = "<blockquote>" & @CRLF & _
" <p>paragraph 1</p>" & @CRLF & _
"</blockquote>" & @CRLF & _
"<p>paragraph 1 outside blockquote</p>" & @CRLF & _
"<blockquote>" & @CRLF & _
" <p>paragraph 2</p>" & @CRLF & _
" <p>paragraph 3</p>" & @CRLF & _
"</blockquote>" & @CRLF & _
"<p>paragraph 2 outside blockquote</p>"
Local $sSubst = "<div>\1</div>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)