use strict;
my $str = 'You should eat fruuits, vegetaaables, and fiiibeeer every day
You should eat fffffruuits, vegettttaaables, and fiber every day
You should eat fruuiiiits, vvvvvegeettaaables, and fibeeer every day';
my $regex = qr/(f+r+u+i+t+s+|v+e+g+e+t+a+b+l+e+s+|f+i+b+e+r+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}