$re = '/(f+r+u+i+t+s+|v+e+g+e+t+a+b+l+e+s+|f+i+b+e+r+)/';
$str = 'You should eat fruuits, vegetaaables, and fiiibeeer every day
You should eat fffffruuits, vegettttaaables, and fiber every day
You should eat fruuiiiits, vvvvvegeettaaables, and fibeeer every day';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);