import re
regex = re.compile(r"(f+r+u+i+t+s+|v+e+g+e+t+a+b+l+e+s+|f+i+b+e+r+)")
test_str = ("You should eat fruuits, vegetaaables, and fiiibeeer every day\n"
"You should eat fffffruuits, vegettttaaables, and fiber every day\n"
"You should eat fruuiiiits, vvvvvegeettaaables, and fibeeer every day")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")