import Foundation
let pattern = #"(f+r+u+i+t+s+|v+e+g+e+t+a+b+l+e+s+|f+i+b+e+r+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
You should eat fruuits, vegetaaables, and fiiibeeer every day
You should eat fffffruuits, vegettttaaables, and fiber every day
You should eat fruuiiiits, vvvvvegeettaaables, and fibeeer every day
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)