#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si).*?<tr>.*?<\/tr>.*?(<tr>).*?<\/tr>.*?"
Local $sString = " <tr>" & @CRLF & _
" <td style="height:24px; width:56px">0,8</td>" & @CRLF & _
" <td style="width:139px">10Х17Н13М2Т</td>" & @CRLF & _
" <td style="width:347px">1,0х2,0(8)</td>" & @CRLF & _
" <td style="width:103px">0,1</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td style="height:24px">1</td>" & @CRLF & _
" <td>08кп</td>" & @CRLF & _
" <td>1,0х2,0</td>" & @CRLF & _
" <td>1,338</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td style="height:24px; width:56px">0,8</td>" & @CRLF & _
" <td style="width:139px">10Х17Н13М2Т</td>" & @CRLF & _
" <td style="width:347px">1,0х2,0(8)</td>" & @CRLF & _
" <td style="width:103px">0,1</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td style="height:24px">1</td>" & @CRLF & _
" <td>08кп</td>" & @CRLF & _
" <td>1,0х2,0</td>" & @CRLF & _
" <td>1,338</td>" & @CRLF & _
" </tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")