// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?si).*?<tr>.*?<\/tr>.*?(<tr>).*?<\/tr>.*?").unwrap();
let string = " <tr>
<td style=\"height:24px; width:56px\">0,8</td>
<td style=\"width:139px\">10Х17Н13М2Т</td>
<td style=\"width:347px\">1,0х2,0(8)</td>
<td style=\"width:103px\">0,1</td>
</tr>
<tr>
<td style=\"height:24px\">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>
<tr>
<td style=\"height:24px; width:56px\">0,8</td>
<td style=\"width:139px\">10Х17Н13М2Т</td>
<td style=\"width:347px\">1,0х2,0(8)</td>
<td style=\"width:103px\">0,1</td>
</tr>
<tr>
<td style=\"height:24px\">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}