use strict;
my $str = ' <tr>
<td style="height:24px; width:56px">0,8</td>
<td style="width:139px">10Х17Н13М2Т</td>
<td style="width:347px">1,0х2,0(8)</td>
<td style="width:103px">0,1</td>
</tr>
<tr>
<td style="height:24px">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>
<tr>
<td style="height:24px; width:56px">0,8</td>
<td style="width:139px">10Х17Н13М2Т</td>
<td style="width:347px">1,0х2,0(8)</td>
<td style="width:103px">0,1</td>
</tr>
<tr>
<td style="height:24px">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>';
my $regex = qr/.*?<tr>.*?<\/tr>.*?(<tr>).*?<\/tr>.*?/sip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}