# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?<tr>.*?<\/tr>.*?(<tr>).*?<\/tr>.*?"
test_str = (" <tr>\n"
" <td style=\"height:24px; width:56px\">0,8</td>\n"
" <td style=\"width:139px\">10Х17Н13М2Т</td>\n"
" <td style=\"width:347px\">1,0х2,0(8)</td>\n"
" <td style=\"width:103px\">0,1</td>\n"
" </tr>\n"
" <tr>\n"
" <td style=\"height:24px\">1</td>\n"
" <td>08кп</td>\n"
" <td>1,0х2,0</td>\n"
" <td>1,338</td>\n"
" </tr>\n"
" <tr>\n"
" <td style=\"height:24px; width:56px\">0,8</td>\n"
" <td style=\"width:139px\">10Х17Н13М2Т</td>\n"
" <td style=\"width:347px\">1,0х2,0(8)</td>\n"
" <td style=\"width:103px\">0,1</td>\n"
" </tr>\n"
" <tr>\n"
" <td style=\"height:24px\">1</td>\n"
" <td>08кп</td>\n"
" <td>1,0х2,0</td>\n"
" <td>1,338</td>\n"
" </tr>")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.