import Foundation
let pattern = #".*?<tr>.*?<\/tr>.*?(<tr>).*?<\/tr>.*?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<tr>
<td style="height:24px; width:56px">0,8</td>
<td style="width:139px">10Х17Н13М2Т</td>
<td style="width:347px">1,0х2,0(8)</td>
<td style="width:103px">0,1</td>
</tr>
<tr>
<td style="height:24px">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>
<tr>
<td style="height:24px; width:56px">0,8</td>
<td style="width:139px">10Х17Н13М2Т</td>
<td style="width:347px">1,0х2,0(8)</td>
<td style="width:103px">0,1</td>
</tr>
<tr>
<td style="height:24px">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)