using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?<tr>.*?<\/tr>.*?(<tr>).*?<\/tr>.*?";
string input = @" <tr>
<td style=""height:24px; width:56px"">0,8</td>
<td style=""width:139px"">10Х17Н13М2Т</td>
<td style=""width:347px"">1,0х2,0(8)</td>
<td style=""width:103px"">0,1</td>
</tr>
<tr>
<td style=""height:24px"">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>
<tr>
<td style=""height:24px; width:56px"">0,8</td>
<td style=""width:139px"">10Х17Н13М2Т</td>
<td style=""width:347px"">1,0х2,0(8)</td>
<td style=""width:103px"">0,1</td>
</tr>
<tr>
<td style=""height:24px"">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}