re = /.*?<tr>.*?<\/tr>.*?(<tr>).*?<\/tr>.*?/i
str = ' <tr>
<td style="height:24px; width:56px">0,8</td>
<td style="width:139px">10Х17Н13М2Т</td>
<td style="width:347px">1,0х2,0(8)</td>
<td style="width:103px">0,1</td>
</tr>
<tr>
<td style="height:24px">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>
<tr>
<td style="height:24px; width:56px">0,8</td>
<td style="width:139px">10Х17Н13М2Т</td>
<td style="width:347px">1,0х2,0(8)</td>
<td style="width:103px">0,1</td>
</tr>
<tr>
<td style="height:24px">1</td>
<td>08кп</td>
<td>1,0х2,0</td>
<td>1,338</td>
</tr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end