#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b0+"
Local $sString = "20100327 15,18,37,39,44,52" & @CRLF & _
"20100328 02,08,24,31,33,50" & @CRLF & _
"20100330 16,26,27,39,40,46" & @CRLF & _
"20100522 05,07,10,11,13,27"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)