const regex = /\b0+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0+', 'gm')
const str = `20100327 15,18,37,39,44,52
20100328 02,08,24,31,33,50
20100330 16,26,27,39,40,46
20100522 05,07,10,11,13,27`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);