import Foundation
let pattern = #"\b0+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
20100327 15,18,37,39,44,52
20100328 02,08,24,31,33,50
20100330 16,26,27,39,40,46
20100522 05,07,10,11,13,27
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)