$re = '/\b0+/m';
$str = '20100327 15,18,37,39,44,52
20100328 02,08,24,31,33,50
20100330 16,26,27,39,40,46
20100522 05,07,10,11,13,27';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;