import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0+";
final String string = "20100327 15,18,37,39,44,52\n"
+ "20100328 02,08,24,31,33,50\n"
+ "20100330 16,26,27,39,40,46\n"
+ "20100522 05,07,10,11,13,27";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}