using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bMove\s+(?:""[^""]*""|\w+(?:\.\w+)*\[\w+]|\d+)\s+)\w+(?:\.\w+)*";
string input = @" Move GLB.SPACES[B] GG_EWE.GG_EWE_IN.GP_EWE_FOCUS
Move 0 GG_EWE.GG_EWE_IN.GP_EWE_PRIORITY
Move ""667"" GG_EWE.GG_EWE_IN.GP_EWE_CODE
Move ""CUS01"" GG_EWE.GG_EWE_IN.GP_EWE_SOURCE[A]
Move ""Invalid customer type's for this screen"" GG_EWE.GG_EWE_IN.GP_EWE_DESC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}