re = /(?<=\bMove\s+(?:"[^"]*"|\w+(?:\.\w+)*\[\w+]|\d+)\s+)\w+(?:\.\w+)*/m
str = ' Move GLB.SPACES[B] GG_EWE.GG_EWE_IN.GP_EWE_FOCUS
Move 0 GG_EWE.GG_EWE_IN.GP_EWE_PRIORITY
Move "667" GG_EWE.GG_EWE_IN.GP_EWE_CODE
Move "CUS01" GG_EWE.GG_EWE_IN.GP_EWE_SOURCE[A]
Move "Invalid customer type\'s for this screen" GG_EWE.GG_EWE_IN.GP_EWE_DESC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end