using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*nameservers.*$\n.*addresses:).*$";
string input = @"network:
ethernets:
enp0s3:
addresses: [10.10.10.5/24]
gateway4: 10.10.10.1
dhcp4: no
nameservers:
addresses: [1.1.1.1, 2.2.2.2]
version: 2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}