use strict;
my $str = 'network:
ethernets:
enp0s3:
addresses: [10.10.10.5/24]
gateway4: 10.10.10.1
dhcp4: no
nameservers:
addresses: [1.1.1.1, 2.2.2.2]
version: 2
';
my $regex = qr/(.*nameservers.*$\n.*addresses:).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}