re = /(.*nameservers.*$\n.*addresses:).*$/m
str = 'network:
ethernets:
enp0s3:
addresses: [10.10.10.5/24]
gateway4: 10.10.10.1
dhcp4: no
nameservers:
addresses: [1.1.1.1, 2.2.2.2]
version: 2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end