package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*nameservers.*$\n.*addresses:).*$`)
var str = `network:
ethernets:
enp0s3:
addresses: [10.10.10.5/24]
gateway4: 10.10.10.1
dhcp4: no
nameservers:
addresses: [1.1.1.1, 2.2.2.2]
version: 2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}