import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*nameservers.*$\\n.*addresses:).*$";
final String string = "network:\n"
+ " ethernets:\n"
+ " enp0s3:\n"
+ " addresses: [10.10.10.5/24]\n"
+ " gateway4: 10.10.10.1\n"
+ " dhcp4: no\n"
+ " nameservers:\n"
+ " addresses: [1.1.1.1, 2.2.2.2]\n"
+ " version: 2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}