using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^(?:[^/]+\/){2})[^/]+";
string substitution = @"a";
string input = @"this/is/some/url";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}