const regex = /(?<=^(?:[^/]+\/){2})[^/]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^(?:[^\/]+\\\/){2})[^\/]+', 'g')
const str = `this/is/some/url`;
const subst = `a`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);